getContentSources Method

Get information about the sources of content when building it for specific ECClasses. Sources involve classes of the primary select instance, its related instances for loading related and navigation properties.

getContentSources(requestOptions: ContentSourcesRequestOptions<IModelConnection> & ClientDiagnosticsAttribute): Promise<SelectClassInfo[]>

Parameter Type Description
requestOptions ContentSourcesRequestOptions<IModelConnection> & ClientDiagnosticsAttribute  

Returns - Promise<SelectClassInfo[]>

Defined in

Last Updated: 15 March, 2024