replaceSelectionWithScope Method

Replace current selection with keys after applying selection scope on them.

replaceSelectionWithScope(source: string, imodel: IModelConnection, ids: Id64Arg, scope: string | SelectionScopeProps | SelectionScope, level: number = 0, rulesetId?: string): Promise<void>

Parameter Type Description
source string Name of the selection source
imodel IModelConnection iModel associated with the selection
ids Id64Arg Element IDs to replace with
scope string | SelectionScopeProps | SelectionScope Selection scope to apply
level number Selection level (see selection levels documentation section)
rulesetId string ID of the ruleset in case the selection was changed from a rules-driven control

Returns - Promise<void>

Defined in

Last Updated: 16 April, 2024