UiItemsProvider Interface

Deprecated  in 3.6. Use UiItemsProvider instead.

Describes interface of objects that want to provide UI component to the running IModelApp.

Implemented by

Methods

Name Description
onUnregister(): void Optional Function called when the provider is unregistered via ItemsManager.unregister to allow provider to do cleanup.  
provideBackstageItems(): BackstageItem[] Optional UiItemsManager calls following method to augment backstage items.  
provideStatusBarItems(stageId: string, stageUsage: string, stageAppData?: any): CommonStatusBarItem[] Optional UiItemsManager calls following method to augment base statusbar for stages that allow it.  
provideToolbarButtonItems(stageId: string, stageUsage: string, toolbarUsage: ToolbarUsage, toolbarOrientation: ToolbarOrientation, stageAppData?: any): CommonToolbarItem[] Optional UiItemsManager calls following method to get items to populate specific toolbars  
provideWidgets(stageId: string, stageUsage: string, location: StagePanelLocation, section?: StagePanelSection, zoneLocation?: AbstractZoneLocation, stageAppData?: any): undefined Optional UiItemsManager calls following method to augment Widget lists.  

Properties

Name Type Description
id Readonly string id of provider  

Defined in

Last Updated: 20 June, 2023