presentation-components

Classes

Name Description
ContentDataProvider Base class for all presentation-driven content providers.
DataProvidersFactory A factory class than can be used to create presentation data providers targeted towards Deprecated
FavoritePropertiesDataFilterer IPropertyDataFilterer implementation which filters favorite properties
FavoritePropertiesDataProvider Presentation Rules-driven element favorite properties data provider implementation.
InstanceKeyValueRenderer Property value renderer for instance keys. Beta
NavigationPropertyEditor Editor for navigation properties. Beta
NavigationPropertyTargetEditor Component that renders navigation property target selector for navigation property value editing. Beta
PresentationLabelsProvider Presentation Rules-driven labels provider implementation.
PresentationPropertyDataProvider Presentation Rules-driven property data provider implementation.
PresentationTableDataProvider Presentation Rules-driven table data provider. Deprecated
PresentationTreeDataProvider Presentation Rules-driven tree data provider.
UnifiedSelectionTreeEventHandler Tree event handler that handles unified selection.

Constants

Name Description
DEFAULT_PROPERTY_GRID_RULESET Default presentation ruleset used by PresentationPropertyDataProvider.
navigationPropertyEditorContext Context used to store data for NavigationPropertyEditor. Beta
TABLE_DATA_PROVIDER_DEFAULT_CACHED_PAGES_COUNT The default number of pages cached by PresentationTableDataProvider Deprecated
TABLE_DATA_PROVIDER_DEFAULT_PAGE_SIZE The default number of rows in a single page requested by PresentationTableDataProvider Deprecated

Enumerations

Name Description
PresentationComponentsLoggerCategory Logger categories used by this package

Global Functions

Name Description
convertToInstanceFilterDefinition Converts PresentationInstanceFilter built by PresentationInstanceFilterBuilder component into Beta
customizeTreeNodeItem Applies customization from Node to TreeNodeItem. Deprecated
isPresentationInfoTreeNodeItem Function that checks if supplied TreeNodeItem is PresentationInfoTreeNodeItem. Beta
isPresentationInstanceFilterConditionGroup Function that checks if supplied PresentationInstanceFilter is PresentationInstanceFilterConditionGroup. Beta
isPresentationTreeNodeItem Function that checks if supplied TreeNodeItem is PresentationTreeNodeItem. Beta
PresentationInstanceFilterBuilder Component for building complex instance filters for filtering Content and Nodes produced by PresentationManager. Beta
PresentationInstanceFilterDialog Dialog component that renders PresentationInstanceFilterBuilder inside. Beta
PresentationTreeNodeRenderer Component for rendering tree nodes produced by PresentationTreeDataProvider. Beta
PresentationTreeRenderer Tree renderer component that enables hierarchy level filtering in trees using PresentationTreeDataProvider. Beta
tableWithUnifiedSelection A HOC component that adds unified selection functionality to the supplied Deprecated
UnifiedSelectionContextProvider Unified Selection context provider. Beta
useControlledPresentationTreeFiltering A custom hook that creates filtered model source and node loader for supplied filter.
useHierarchyLevelFiltering Custom hook that creates callbacks for filtering hierarchy levels in the tree. Beta
useNavigationPropertyEditingContext Custom hook that creates value for navigationPropertyEditorContext. Beta
usePresentationInstanceFilteringProps Custom hook that extracts properties and classes from Descriptor and creates props that can be used by InstanceFilterBuilder component. Beta
usePresentationTreeNodeLoader Custom hooks which creates PagedTreeNodeLoader with PresentationTreeDataProvider using
usePropertyDataProviderWithUnifiedSelection A React hook that adds unified selection functionality to the provided data provider.
useRulesetRegistration Custom hook which registers supplied Ruleset on mount and removes on unmount.
useUnifiedSelectionContext Returns Unified Selection context provided by UnifiedSelectionContextProvider. Beta
useUnifiedSelectionTreeEventHandler A custom hook which creates and disposes UnifiedSelectionTreeEventHandler
viewWithUnifiedSelection A HOC component that adds unified selection functionality to the supplied

Interfaces

Name Description
CacheInvalidationProps Properties for invalidating content cache.
ContentDataProviderProps Properties for creating a ContentDataProvider instance.
ControlledPresentationTreeFilteringProps Parameters for useControlledPresentationTreeFiltering hook
DataProvidersFactoryProps Data structure holding initialization properties for DataProvidersFactory Deprecated
DiagnosticsProps Settings for capturing diagnostics data.
FavoritePropertiesDataFiltererProps Props for FavoritePropertiesDataFilterer.
FavoritePropertiesDataProviderProps Props for FavoritePropertiesDataProvider
IContentDataProvider Interface for all presentation-driven content providers.
IFavoritePropertiesDataProvider An data provider interface for returning favorite properties for the given elements
IFilteredPresentationTreeDataProvider Filtered presentation tree data provider.
IPresentationDataProvider Interface for a presentation data provider
IPresentationLabelsProvider Interface for presentation rules-driven labels provider.
IPresentationTreeDataProvider Presentation tree data provider.
IUnifiedSelectionComponent An interface for all unified selection components
NavigationPropertyEditorContextProps Data structure that describes navigationPropertyEditorContext value. Beta
PresentationInfoTreeNodeItem Data structure that describes tree node item created by PresentationTreeDataProvider Beta
PresentationInstanceFilterBuilderProps Props for PresentationInstanceFilterBuilder component. Beta
PresentationInstanceFilterCondition Data structure that describes single filter condition. Beta
PresentationInstanceFilterConditionGroup Data structure that describes group of filter condition joined by logical operator. Beta
PresentationInstanceFilterDialogProps Props for PresentationInstanceFilterDialog component. Beta
PresentationInstanceFilterInfo Data structure that stores information about filter built by PresentationInstanceFilterBuilder. Beta
PresentationLabelsProviderProps Properties for creating a LabelsProvider instance.
PresentationPropertyDataProviderProps Properties for creating a PresentationPropertyDataProvider instance.
PresentationTableDataProviderProps Initialization properties for PresentationTableDataProvider Deprecated
PresentationTreeDataProviderDataSourceEntryPoints Definitions of methods used by PresentationTreeDataProvider to get nodes' data. Beta
PresentationTreeDataProviderProps Properties for creating a PresentationTreeDataProvider instance.
PresentationTreeNodeItem Data structure that describes tree node item created by PresentationTreeDataProvider. Beta
PresentationTreeNodeItemFilteringInfo Data structure that describes information for tree item hierarchy level filtering. Beta
PresentationTreeNodeLoaderProps Properties for usePresentationTreeNodeLoader hook.
PresentationTreeNodeLoaderResult Return type for usePresentationTreeNodeLoader hook.
PresentationTreeNodeRendererProps Props for PresentationTreeNodeRenderer component. Beta
PresentationTreeRendererProps Props for PresentationTreeRenderer component. Beta
PropertyDataProviderWithUnifiedSelectionProps Props for the usePropertyDataProviderWithUnifiedSelection hook
TableWithUnifiedSelectionProps Props that are injected to the TableWithUnifiedSelection HOC component. Deprecated
UnifiedSelectionContext Interface for accessing and modifying Unified Selection within React components. Beta
UnifiedSelectionContextProviderProps Props for Unified Selection context provider. Beta
UnifiedSelectionTreeEventHandlerParams Data structure that describes parameters for UnifiedSelectionTreeEventHandler
UseHierarchyLevelFilteringProps Props for useHierarchyLevelFiltering hook. Beta
UsePropertyDataProviderWithUnifiedSelectionResult usePropertyDataProviderWithUnifiedSelection return type.
ViewWithUnifiedSelectionProps Props that are injected to the ViewWithUnifiedSelection HOC component.

Namespaces

Name Description
CacheInvalidationProps

Type Aliases

Name Description
IPresentationPropertyDataProvider Interface for presentation rules-driven property data provider.
IPresentationTableDataProvider Interface for presentation rules-driven table data provider. Deprecated
PresentationInstanceFilter Type that describes instance filter based on Descriptor fields. Beta
UnifiedSelectionState

Last Updated: 20 June, 2023