core-transformer

Classes

Name Description
IModelCloneContext The context for transforming a source Element to a target Element and remapping internal identifiers to the target iModel. Beta
IModelExporter Base class for exporting data from an iModel. Beta
IModelExportHandler Handles the events generated by IModelExporter. Beta
IModelImporter Base class for importing data into an iModel. Beta
IModelTransformer Base class used to transform a source iModel into a different target iModel. Beta
PendingReferenceMap a map that supports using PendingReferences objects as structural keys,
TemplateModelCloner IModelTransformer that clones the contents of a template model. Beta

Enumerations

Name Description
TransformerLoggerCategory Logger categories used by this package

Interfaces

Name Description
ExportSchemaResult Beta
IModelImportOptions Options provided to the IModelImporter constructor. Beta
IModelTransformOptions Options provided to the IModelTransformer constructor. Beta
InitFromExternalSourceAspectsArgs Arguments you can pass to IModelTransformer.initExternalSourceAspects Beta
OptimizeGeometryOptions Options provided to IModelImporter.optimizeGeometry specifying post-processing optimizations to be applied to the iModel's geometry. Beta

Namespaces

Name Description
PendingReference

Last Updated: 20 June, 2023