AccuDrawInputFieldProps Interface

Beta  

Properties for AccuDrawInputField component

Extends

Methods

Name Description
onEnterPressed(): void Optional Listens for keypress  
onEscPressed(): void Optional Listens for keypress  
onValueChanged(stringValue: string): void Triggered when the content is changed  

Properties

Name Type Description
field ItemField Which AccuDraw field this represents  
iconSpec undefined | IconSpec icon for the input element  
id string id for the input element  
isLocked undefined | boolean Indicates whether field is locked  
label undefined | string label for the input element  
labelCentered undefined | boolean Center justified label  
labelClassName undefined | string Custom CSS class name for the label  
labelStyle undefined | CSSProperties Custom CSS Style for the label  
ref undefined | Ref<HTMLInputElement> Provides ability to return reference to HTMLInputElement  
valueChangedDelay undefined | number Frequency to poll for changes in value, in milliseconds  

Inherited properties

Name Type Inherited from Description
className undefined | string CommonProps Custom CSS class name
itemId undefined | string CommonProps Optional unique identifier for item.
style undefined | CSSProperties CommonProps Custom CSS style properties

Defined in

Last Updated: 20 June, 2023