createControl MethodStatic

Deprecated  in 3.7. Use create method.

Creates a control registered by calling registerControl.

createControl(classId: string, uniqueId: string, options?: any, controlId?: string): undefined | ConfigurableUiElement

Parameter Type Description
classId string the class id of the control to create
uniqueId string a unique id for the control
options any options passed to the constructor of the control
controlId string controlId which may not be unique across all control instances.

Returns - undefined | ConfigurableUiElement

the created control

Defined in

Last Updated: 20 June, 2023