registerControl MethodStatic

Deprecated  in 3.7. Use register method.

Registers a control implementing the ConfigurableUiElement interface. These controls can be a ContentControl, NavigationAidControl, StatusBarWidgetControl, WidgetControl or ToolUiProvider.

registerControl(classId: string, constructor: ConfigurableUiControlConstructor): void

Parameter Type Description
classId string the class id of the control to register
constructor ConfigurableUiControlConstructor the constructor of the control to register

Returns - void

Defined in

Last Updated: 20 June, 2023