ModalFrontstageProps Interface

Properties for the ModalFrontstage React component

Extends

Methods

Name Description
closeModal(): any Callback for closing the modal Frontstage.  
navigateBack(): any Optional Callback for navigating back from the modal Frontstage.  

Properties

Name Type Description
appBarRight undefined | ReactNode An optional React node displayed in the upper right of the modal Frontstage.  
isOpen undefined | boolean Indicates whether the modal Frontstage is open  
title string Title displayed at the top of the modal Frontstage  

Inherited properties

Name Type Inherited from Description
className undefined | string CommonProps Custom CSS class name
itemId undefined | string CommonProps Optional unique identifier for item.
style undefined | CSSProperties CommonProps Custom CSS style properties

Defined in

Last Updated: 20 June, 2023