ActionItemButtonProps Interface

Deprecated  in 3.5. Props of a deprecated component.

Properties that must be specified for an ActionItemButton component

Extends

Methods

Name Description
onSizeKnown(size: SizeProps): void Optional Called when the button is initialized and the size is known  

Properties

Name Type Description
actionItem ActionButtonItemDef Action Button item definition containing the action information  
isEnabled undefined | boolean Indicates whether the button is enabled or disabled  

Inherited properties

Name Type Inherited from Description
className undefined | string CommonProps Custom CSS class name
itemId undefined | string CommonProps Optional unique identifier for item.
style undefined | CSSProperties CommonProps Custom CSS style properties

Defined in

Last Updated: 20 June, 2023