ItemProps Interface

Definition that specifies properties shared between many ConfigurableUi components.

Extends

Methods

Name Description
stateFunc(state: Readonly<BaseItemState>): BaseItemState Optional Function called to get the new items state Deprecated  

Properties

Name Type Description
applicationData undefined | any can be used by application to store miscellaneous data.  
badgeType undefined | BadgeType Badge to be overlaid on the item.  
description string | ConditionalStringValue | StringGetter if set, it is used to explicitly set the description shown by a component.  
descriptionKey undefined | string if set, it is used to define a key that is used to look up a localized string.  
icon string | ConditionalStringValue abstract icon definition, used when create itemDef from abstract item (ie.  
isActive undefined | boolean if set, component will be considered "active" an will display an "active stripe" - defaults to false  
isDisabled boolean | ConditionalBooleanValue if true component will be disabled - defaults to false  
isEnabled undefined | boolean if set, component will be enabled - defaults to true Deprecated  
isHidden boolean | ConditionalBooleanValue if true component will be hidden - defaults to false  
isPressed undefined | boolean if set, component will be considered selected but will NOT display an "active stripe" - defaults to false.  
isVisible undefined | boolean if set, component will be visible - defaults to true Deprecated  
label string | ConditionalStringValue | StringGetter if set, it is used to explicitly set the label shown by a component.  
labelKey undefined | string if set, it is used to define a key that is used to look up a localized string.  
stateSyncIds undefined | string[] Synchronize Ids to listen for Deprecated  
tooltip string | ConditionalStringValue | StringGetter used to explicitly set the tooltip shown by a component.  
tooltipKey undefined | string if set, it is used to define a key that is used to look up a localized string.  

Inherited properties

Name Type Inherited from Description
className undefined | string IconProps Custom CSS class name
iconSpec undefined | IconSpec IconProps CSS class name or SvgSprite/SvgPath for icon.
itemId undefined | string IconProps Optional unique identifier for item.
style undefined | CSSProperties IconProps Custom CSS style properties

Defined in

Last Updated: 20 June, 2023