UiSettingsPage Function

Beta  

UiSettingsPage displaying the active UI settings. This page lets users set the following settings.

  • theme - Dark, Light, or based on OS preference.
  • auto hide - Starts a timer and blanks out ui components that overlay content if there is no mouse movement for a period of time.
  • drag interaction - If set, toolbar group buttons require a press and drag or a long press to open. In this mode a child action item is shown as the group button and is activated when button is clicked. If a different child item is selected, it becomes the active group button item.
  • use proximity - Changes the opacity of toolbar from transparent to opaque as the mouse moves closer.
  • snap widget opacity - triggers an abrupt change from transparent to opaque for tool and navigation widgets, instead of a gradual change based on mouse location.
  • widget opacity - determines how transparent floating widgets in V2 and all widgets in V1 become when the mouse in not in them.
  • UI version - if allowed by props, the UI version can be toggled between V1 and V2.

UiSettingsPage(): JSX.Element

Returns - JSX.Element

UiSettingsPage(__namedParameters: { allowSettingUiFrameworkVersion: boolean }): JSX.Element

Parameter Type Description
__namedParameters { allowSettingUiFrameworkVersion: boolean }  

Returns - JSX.Element

Defined in

Last Updated: 20 June, 2023