StatusBarIndicatorProps Interface

Beta  

Properties of StatusBarIndicator component.

Extends

Methods

Name Description
onClick(): void Optional Function called when indicator is clicked.  

Properties

Name Type Description
children undefined | ReactNode Indicator content.  
defaultIsOpen undefined | boolean Default state of an indicator popup.  
popup undefined | ReactNode Content to display in a popup when indicator is clicked.  
title undefined | string Title of an indicator.  

Inherited properties

Name Type Inherited from Description
className undefined | string CommonProps Custom CSS class name
itemId undefined | string CommonProps Optional unique identifier for item.
style undefined | CSSProperties CommonProps Custom CSS style properties

Defined in

Last Updated: 20 June, 2023