StatusBarWidgetControlArgs Interface

Status Bar Widget Control render prop arguments.

Methods

Name Description
onOpenWidget(widget: StatusBarFieldId): void Function called when the widget is being opened or closed. Deprecated  

Properties

Name Type Description
isInFooterMode boolean Describes whether the footer is in widget or footer mode. Deprecated  
openWidget StatusBarFieldId Currently open widget or null if no widget is open. Deprecated  
toastTargetRef Ref<HTMLElement> Element reference to which the toast will animate out to.  

Defined in

Last Updated: 20 June, 2023