CommonWidgetProps Interface

Beta  

Properties of a Widget.

Extends

Inherited methods

Name Inherited from Description
getWidgetContent(): any Readonly Readonly Gets the widget content.
onWidgetStateChanged(): void OptionalReadonly Readonly Handler for widget state changed event
restoreTransientState(): boolean OptionalReadonly Readonly Restore transient DOM state.
saveTransientState(): void OptionalReadonly Readonly Save transient DOM state (i.e.
stateFunc(state: Readonly<WidgetState>): WidgetState OptionalReadonly Readonly Function executed to determine the state of the widget.

Properties

Name Type Description
id Readonly string Id used to uniquely identify the widget.  

Inherited properties

Name Type Inherited from Description
allowedPanelTargets Readonly undefined | Readonly Optional prop specifying which Panel sides can be docking targets for this widget.
applicationData Readonly undefined | any Readonly Application data attached to the Widget.
badgeType Readonly undefined | BadgeType Readonly Badge to be overlaid on the widget tab.
canPopout Readonly undefined | boolean Readonly Indicates if widget can be popped out to a child window.
defaultFloatingPosition Readonly undefined | { x: number, y: number } Readonly Defines that default Top Left position when widget is floated via API calls
defaultFloatingSize Readonly undefined | { height: number, width: number } Readonly Optional default size to use when floating a widget.
defaultState Readonly undefined | WidgetState Readonly Default Widget state.
fillZone Readonly undefined | boolean Readonly Indicates whether this Widget should fill the available space in the Zone.
floatingContainerId Readonly undefined | string Readonly If the widget state is changed to floating and the floatingContainerId is defined, the widget will be added to a
hideWithUiWhenFloating Readonly undefined | boolean Readonly Optional prop that tells the widget system to fade this widget out with the rest of the UI when it is in floating state
icon Readonly string | ConditionalStringValue Readonly Name of icon WebFont entry or if specifying an imported SVG symbol use "webSvg:" prefix to imported symbol Id.
internalData Readonly undefined | Map<string, any> Readonly optional data to used by item implementor.
isFloatingStateSupported Readonly undefined | boolean Readonly Indicates if widget can be in floating state, default to true.
isFloatingStateWindowResizable Readonly undefined | boolean Readonly Indicates if floating widget is resizable, defaults to false which caused the widget to be auto-sized..
isFreeform Readonly undefined | boolean Readonly Indicates whether the Widget is free-form or rectangular.
isStatusBar Readonly undefined | boolean Readonly Indicates whether this Widget is for the Status Bar.
isToolSettings Readonly undefined | boolean Readonly Indicates whether this Widget is for the Tool Settings.
label Readonly string | ConditionalStringValue Readonly if set, component will be considered selected but will NOT display an "active stripe" - defaults to false.
priority Readonly undefined | number Readonly Widget priority
providerId Readonly undefined | string Readonly id of UiItemsProvider
syncEventIds Readonly undefined | string[] Readonly Defines the SyncUi event Ids that will trigger the stateFunc to run to determine the state of the widget.
tooltip Readonly string | ConditionalStringValue Readonly used to explicitly set the tooltip shown by a component.

Defined in

Last Updated: 20 June, 2023