BreadcrumbProps Interface

Deprecated  in 3.0. Use Breadcrumbs from @itwin/itwinui-react.

Beta  

Properties for Breadcrumb component

Extends

Methods

Name Description
onChildrenLoaded(parent: TreeNodeItem, children: TreeNodeItem[]): void Optional Callback triggered when child node is loaded with an asynchronous dataProvider.  
onRender(): void Optional    
onRootNodesLoaded(nodes: TreeNodeItem[]): void Optional Callback triggered when root nodes are loaded with an asynchronous dataProvider.  

Properties

Name Type Description
background undefined | boolean Whether to show white background and border.  
dataProvider TreeDataProvider Data provider for tree content  
delimiter undefined | string Character used to separate discrete tree nodes in Breadcrumb text mode.  
dropdownOnly undefined | boolean Disable plain-text input for the breadcrumb navigation.  
initialBreadcrumbMode undefined | BreadcrumbMode Which BreadcrumbMode to initially start with.  
initialCurrent undefined | TreeNodeItem Initial current node  
parentsOnly undefined | boolean Whether to disallow navigation to leaf nodes (nodes with no children).  
path undefined | BreadcrumbPath Manager to coordinate state between Breadcrumb element and BreadcrumbDetails element.  
showUpDir undefined | boolean Whether to show up-dir directory pop button on the left.  
staticOnly undefined | boolean Static breadcrumb element.  
width string | number Width in pixels, if number, and in specified css units, if string.  

Inherited properties

Name Type Inherited from Description
className undefined | string CommonProps Custom CSS class name
itemId undefined | string CommonProps Optional unique identifier for item.
style undefined | CSSProperties CommonProps Custom CSS style properties

Defined in

Last Updated: 20 June, 2023