ShowHideMenuProps<T extends ShowHideID> Interface

Properties for the ShowHideMenu component

Extends

Methods

Name Description
onClose(): void Optional Called when close button is clicked  
onShowHideChange(cols: T[]): undefined | boolean Optional Called when item is shown/hidden  

Inherited methods

Name Inherited from Description
onEsc(data: any): any Optional GlobalContextMenuProps when Escape button is pressed
onOutsideClick(event: MouseEvent): any Optional GlobalContextMenuProps When click is registered outside of ContextMenu.
onSelect(event: any): any Optional GlobalContextMenuProps When list item or submenu is selected

Properties

Name Type Description
initialHidden undefined | T[] Hidden list to start with  
items ShowHideItem<T>[] key-label pair list for id's to be shown/hidden, and an accompanying label.  
opened boolean Whether dialog is opened or closed  
x number X position to place menu  
y number Y position to place menu  

Inherited properties

Name Type Inherited from Description
autoflip undefined | boolean GlobalContextMenuProps Whether menu flips directions based on screen edge.
className undefined | string GlobalContextMenuProps Custom CSS class name
contextMenuComponent undefined | ComponentType<ContextMenuProps> GlobalContextMenuProps Context menu element.
direction undefined | ContextMenuDirection GlobalContextMenuProps Which direction the menu opens.
edgeLimit undefined | boolean GlobalContextMenuProps Whether menu hugs screen edge when autoflip is off.
floating undefined | boolean GlobalContextMenuProps whether menu floats on the viewport, or the page.
hotkeySelect undefined | boolean GlobalContextMenuProps Whether Hotkey press selects item, or just highlights item.
identifier undefined | string GlobalContextMenuProps Unique identifier, to distinguish from other GlobalContextMenu components.
itemId undefined | string GlobalContextMenuProps Optional unique identifier for item.
selectedIndex undefined | number GlobalContextMenuProps starting menu item selected index Default: -1
style undefined | CSSProperties GlobalContextMenuProps Custom CSS style properties

Defined in

Last Updated: 20 June, 2023