DropTargetProps<DragDropObject> Interface

Deprecated  in 2.x. Obsolete.

Beta  

Properties and callbacks for the withDragSource Higher-Order Component.

Methods

Name Description
canDropTargetDrop(args: DropTargetArguments<DragDropObject>): boolean Optional Determines whether item may be dropped on DropTarget.  
onDropTargetDrop(args: DropTargetArguments<DragDropObject>): DropTargetArguments<DragDropObject> Optional Triggered when item is dropped on wrapped component.  
onDropTargetOver(args: DropTargetArguments<DragDropObject>): void Optional Triggered when item is dragged over wrapped component.  

Properties

Name Type Description
objectTypes string | symbol[] | () => string | symbol[] List of allowed object types  

Defined in

Last Updated: 20 June, 2023