PropertyViewProps Interface

Properties of PropertyView React component

Extends

Methods

Name Description
valueElementRenderer(): ReactNode Optional Render callback for property value.  

Inherited methods

Name Inherited from Description
onClick(property: PropertyRecord, key?: string): void Optional SharedRendererProps Called when property gets clicked.
onColumnRatioChanged(ratio: number): void | RatioChangeResult Optional SharedRendererProps Callback to column ratio changed event
onContextMenu(property: PropertyRecord, e: MouseEvent<Element, MouseEvent>): void Optional SharedRendererProps Called to show a context menu for properties
onResizeHandleDragChanged(isDragStarted: boolean): void Optional SharedRendererProps Callback to drag event change
onResizeHandleHoverChanged(isHovered: boolean): void Optional SharedRendererProps Callback to hover event change
onRightClick(property: PropertyRecord, key?: string): void Optional SharedRendererProps Called when property gets right clicked.

Properties

Name Type Description
labelElement ReactNode Property label as a React element  
valueElement undefined | ReactNode Property value as a React element  

Inherited properties

Name Type Inherited from Description
actionButtonRenderers undefined | ActionButtonRenderer[] SharedRendererProps Array of action button renderers
columnInfo undefined | SharedRendererProps Information for styling property grid columns
columnRatio undefined | number SharedRendererProps Ratio between label and value cells
isHoverable undefined | boolean SharedRendererProps Indicates that properties have hover effect
isResizeHandleBeingDragged undefined | boolean SharedRendererProps Is resize handle being dragged
isResizeHandleHovered undefined | boolean SharedRendererProps Is resize handle hovered
isSelectable undefined | boolean SharedRendererProps Indicates that properties can be selected
isSelected undefined | boolean SharedRendererProps Controls component selection
orientation Orientation SharedRendererProps Orientation to use for displaying the property
propertyRecord PropertyRecord SharedRendererProps PropertyRecord to render
uniqueKey undefined | string SharedRendererProps Unique string, that identifies this property component.
width undefined | number SharedRendererProps Width of the whole property element

Defined in

Last Updated: 20 June, 2023