CommonPropertyGridProps Interface

Common Property Grid Props to be used by Property Grid Variants

Extends

Methods

Name Description
onPropertyContextMenu(args: PropertyGridContextMenuArgs): void Optional Called to show a context menu when properties are right-clicked  
onPropertyEditing(args: PropertyEditingArgs, category: PropertyCategory): void Optional Callback for when properties are being edited  
onPropertySelectionChanged(property: PropertyRecord): void Optional Callback to property selection  
onPropertyUpdated(args: PropertyUpdatedArgs, category: PropertyCategory): Promise<boolean> Optional Callback for when properties are updated  

Properties

Name Type Description
actionButtonRenderers undefined | ActionButtonRenderer[] Array of action button renderers.  
actionButtonWidth undefined | number Fixed action button column width  
horizontalOrientationMinWidth undefined | number The minimum width before the auto-switch to Vertical when the width is too narrow.  
isOrientationFixed undefined | boolean Indicates whether the orientation is fixed and does not auto-switch to Vertical when the width is too narrow.  
isPropertyEditingEnabled undefined | boolean Enables/disables property editing  
isPropertyHoverEnabled undefined | boolean Enables/disables property hovering effect  
isPropertySelectionEnabled undefined | boolean Enables/disables property selection  
isPropertySelectionOnRightClickEnabled undefined | boolean Enables/disables property selection with right click  
minLabelWidth undefined | number Minimum allowed label column width, after which resizing stops  
minValueWidth undefined | number Minimum allowed value column width, after which resizing stops  
orientation undefined | Orientation Grid orientation.  
propertyValueRendererManager undefined | PropertyValueRendererManager Custom property value renderer manager  

Inherited properties

Name Type Inherited from Description
className undefined | string CommonProps Custom CSS class name
itemId undefined | string CommonProps Optional unique identifier for item.
style undefined | CSSProperties CommonProps Custom CSS style properties

Defined in

Last Updated: 20 June, 2023