OperatorValueFilterDescriptor Interface

Deprecated  in 3.5. Use the Table component in @itwin/itwinui-react instead, which does not use this interface.

An abstraction for all filter descriptors that have an operator and a value

Extends

Inherited methods

Name Inherited from Description
clear(): void FilterDescriptor Clears the filter descriptor and sets it to inactive.
evaluateRow(row: RowItem): boolean FilterDescriptor Evaluates a row for filtering.
getFilterExpression(): string FilterDescriptor Returns filter as ECExpression.
isFilterForColumn(columnKey: string): boolean FilterDescriptor Determines if this filter is for a particular column.

Properties

Name Type Description
isCaseSensitive boolean Determines if the filtering is case sensitive.  
memberKey string Gets the member (key).  
memberType string Gets the member type.  
operator FilterOperator Gets the operator for the filter.  
value any Gets the value for the filter.  

Inherited properties

Name Type Inherited from Description
isActive boolean FilterDescriptor Gets a value indicating whether this filter is active.

Defined in

Last Updated: 20 June, 2023