TableProps Interface

Deprecated  in 3.0. Use the Table component in @itwin/itwinui-react instead, which does not use this interface.

Properties for the Table React component

Extends

Methods

Name Description
isCellSelected(rowIndex: number, cell: CellItem): boolean Optional Callback for determining if cell is selected  
isRowSelected(row: RowItem): boolean Optional Callback for determining if row is selected  
onApplyFilter(): void Optional    
onCellContextMenu(args: TableCellContextMenuArgs): void Optional Called to show a context menu when a cell is right-clicked.  
onCellsDeselected(cellIterator: AsyncIterableIterator<[RowItem, CellItem]>): Promise<boolean> Optional Callback for when cells are deselected  
onCellsSelected(cellIterator: AsyncIterableIterator<[RowItem, CellItem]>, replace: boolean): Promise<boolean> Optional Callback for when cells are selected  
onPropertyEditing(args: TableCellEditorState): void Optional Callback for when properties are being edited  
onPropertyUpdated(propertyArgs: PropertyUpdatedArgs, cellArgs: TableCellUpdatedArgs): Promise<boolean> Optional Callback for when properties are updated  
onRender(): void Optional Gets called when rendering is finished.  
onRowsDeselected(rowIterator: AsyncIterableIterator<RowItem>): Promise<boolean> Optional Callback for when rows are deselected  
onRowsLoaded(firstRowIndex: number, lastRowIndex: number): void Optional Called when rows are loaded  
onRowsSelected(rowIterator: AsyncIterableIterator<RowItem>, replace: boolean): Promise<boolean> Optional Callback for when rows are selected  
onScrollToRow(rowIndex: number): void Optional    
renderRow(item: RowItem, props: ): ReactNode Optional    

Properties

Name Type Description
dataProvider TableDataProvider Data provider for the Table  
hideHeader undefined | boolean Hide the header  
maximumDistinctValues undefined | number Maximum number of distinct values for filtering  
pageAmount undefined | number Amount of rows per page.  
propertyValueRendererManager undefined | PropertyValueRendererManager Custom property value renderer manager  
reorderableColumns undefined | boolean Indicates whether the Table columns are reorderable  
scrollToRow undefined | number Specifies a row index to scroll to  
selectionMode undefined | SelectionMode Specifies the selection mode.  
settingsIdentifier undefined | string Identifying string used for persistent state.  
settingsStorage undefined | UiStateStorage Optional parameter for persistent UI settings.  
showHideColumns undefined | boolean Enables context menu to show/hide columns  
stripedRows undefined | boolean Alternate the background of odd and even rows  
tableSelectionTarget undefined | TableSelectionTarget Specifies the selection target.  
uiStateStorage undefined | UiStateStorage Optional parameter for persistent UI settings. Deprecated  

Inherited properties

Name Type Inherited from Description
className undefined | string CommonProps Custom CSS class name
itemId undefined | string CommonProps Optional unique identifier for item.
style undefined | CSSProperties CommonProps Custom CSS style properties

Defined in

Last Updated: 20 June, 2023