ToolbarButtonItemProps Interface

Properties of ToolbarButtonItem component.

Extends

Methods

Name Description
onClick(): void Optional Function called when the item is clicked.  
onKeyDown(e: KeyboardEvent<Element>): void Optional Function called when a key is pressed.  

Properties

Name Type Description
addGroupSeparator undefined | boolean If true add a gap before button.  
badge undefined | ReactNode A badge to draw.  
groupPriority undefined | number value added to DOM element as a data attribute  
icon undefined | ReactNode button icon.  
isActive undefined | boolean Describes if item is active.  
isDisabled undefined | boolean Describes if the item is disabled.  
itemPriority undefined | number value added to DOM element as a data attribute, shows 0 is undefined  
providerId undefined | string value added to DOM element as a data attribute to hold name of items provider.  
title string Title for the item.  

Inherited properties

Name Type Inherited from Description
className undefined | string CommonProps Custom CSS class name
itemId undefined | string CommonProps Optional unique identifier for item.
style undefined | CSSProperties CommonProps Custom CSS style properties

Defined in

Last Updated: 20 June, 2023