ToolbarWithOverflowProps Interface

Properties of ToolbarWithOverflow component.

Extends

Methods

Name Description
onKeyDown(e: KeyboardEvent<Element>): void Optional Optional function to call on any KeyDown events processed by toolbar  

Properties

Name Type Description
expandsTo undefined | Direction Describes to which direction the popup panels are expanded.  
items CommonToolbarItem[] Definitions for items of the toolbar.  
onItemExecuted undefined | OnItemExecutedFunc Optional function to call on any item execution  
overflowExpandsTo undefined | Direction Describes to which direction the overflow popup panels are expanded.  
panelAlignment undefined | ToolbarPanelAlignment Describes how expanded panels are aligned.  
toolbarOpacitySetting undefined | ToolbarOpacitySetting Determines whether to use mouse proximity to alter the opacity of the toolbar  
useDragInteraction undefined | boolean Use Drag Interaction to open popups with nest action buttons  

Inherited properties

Name Type Inherited from Description
children undefined | undefined NoChildrenProps  
className undefined | string CommonProps Custom CSS class name
itemId undefined | string CommonProps Optional unique identifier for item.
style undefined | CSSProperties CommonProps Custom CSS style properties

Defined in

Last Updated: 20 June, 2023