TreeNodeEditorProps Interface

Properties for TreeNodeEditor component.

Methods

Name Description
onCancel(): void Callback that is called when editing is canceled.  
onCommit(node: TreeModelNode, newValue: string): void Callback that is called when changes are committed.  

Properties

Name Type Description
node TreeModelNode Tree node which is in editing mode.  
style undefined | CSSProperties Editor style.  

Defined in

Last Updated: 20 June, 2023