LockState Enumeration

The state of a lock.

Members

Name Value Description
None 0 The element is not locked
Shared 1 Holding a shared lock on an element blocks other users from acquiring the Exclusive lock it. More than one user may acquire the shared lock.
Exclusive 2 A Lock that permits modifications to an element and blocks other users from making modifications to it.
Holding an exclusive lock on an "owner" (a model or a parent element), implicitly exclusively locks all its members.

Defined in

Last Updated: 20 June, 2023