ExportPartGraphicsOptions Interface

Parameters for IModelDb.exportPartGraphics

Properties

Name Type Description
angleTol undefined | number Max angle difference in radians for approximated face, see StrokeOptions.  
chordTol undefined | number Max distance from a face to the original geometry, see StrokeOptions.  
decimationTol undefined | number Max distance between mesh vertices for them to be collapsed.  
displayProps ExportPartDisplayInfo The base display properties to use for generating the graphics.  
elementId string The ID for the source GeometryPart  
maxEdgeLength undefined | number Max length of any edge in generated faces, see StrokeOptions  
minBRepFeatureSize undefined | number BRep features with bounding boxes smaller than this size will not generate graphics.  
minLineStyleComponentSize undefined | number The longest dimension of a line style's largest component must be at least this size in order for  
onPartGraphics ExportPartFunction A function to call for each unique color and texture combination.  
onPartLineGraphics undefined | ExportPartLinesFunction An optional function to call if line graphics are desired.  

Defined in

Last Updated: 20 June, 2023