collectReferenceIds MethodProtected

Beta  

Collect the Ids of this entity's references at this level of the class hierarchy. A reference is any entity referenced by this entity's EC Data This is important for cloning operations but can be useful in other situations as well.

collectReferenceIds(referenceIds: Set<string>): void

note In the next breaking change, the behavior of this function will change to require a EntityReferenceSet argument, which does not accept plain Id64s, see EntityReferenceSet.

note In order to clone/transform an entity, all referenced elements must have been previously cloned and remapped within the IModelCloneContext.

note This should be overridden (with super called) at each level the class hierarchy that introduces references.

see Entity.getReferenceIds

Parameter Type Description
referenceIds Set<string>  

Returns - void

Defined in

Last Updated: 20 June, 2023