WorkspaceContainer Namespace

Beta  

Interface

Name Description
WorkspaceContainer.Alias A member named containerName that specifies by an entry in a "cloud/containers" setting
WorkspaceContainer.Props Properties that specify a WorkspaceContainer.

Type alias

Name Description
WorkspaceContainer.Id The unique identifier of a WorkspaceContainer.
WorkspaceContainer.Name The name of a WorkspaceContainer in a "cloud/containers" setting.
WorkspaceContainer.TokenFunc  

Defined in

WorkspaceContainer Interface

Beta  

A WorkspaceContainer holds WorkspaceDbs. Access rights are administered per WorkspaceContainer. That is, if a user has rights to access a WorkspaceContainer, that right applies to all WorkspaceDbs in the WorkspaceContainer.

Methods

Name Description
addWorkspaceDb(toAdd: ): void    
close(): void Close this WorkspaceContainer.  
dropWorkspaceDb(container: WorkspaceDb): void Close and remove a currently opened WorkspaceDb from this Workspace.  
getWorkspaceDb(props: WorkspaceDb.Props): WorkspaceDb find or open a WorkspaceDb from this WorkspaceContainer.  
resolveDbFileName(props: WorkspaceDb.Props): string    

Properties

Name Type Description
filesDir Readonly string the local directory where this WorkspaceContainer will store temporary files extracted for file-resources.  
id Readonly string The unique identifier for a WorkspaceContainer a cloud storage account.  
workspace Readonly Workspace Workspace holding this WorkspaceContainer.  

Defined in

Last Updated: 20 June, 2023