ContextRealityModelProps Namespace

Function

Name Description
ContextRealityModelProps.clone Produce a deep copy of input.

Defined in

ContextRealityModelProps Interface

JSON representation of a ContextRealityModel.

extensions

Properties

Name Type Description
appearanceOverrides undefined | FeatureAppearanceProps See ContextRealityModel.appearanceOverrides.  
classifiers undefined | SpatialClassifierProps[] See ContextRealityModel.classifiers.  
description undefined | string An optional, user-friendly description of the reality model suitable for display in a user interface.  
displaySettings undefined | RealityModelDisplayProps See ContextRealityModel.displaySettings. Beta  
name undefined | string An optional, user-friendly name for the reality model suitable for display in a user interface.  
orbitGtBlob undefined | See ContextRealityModel.orbitGtBlob.  
planarClipMask undefined | PlanarClipMaskProps See ContextRealityModel.planarClipMask.  
rdSourceKey undefined | RealityDataSourceKey See ContextRealityModel.rdSourceKey. Beta  
realityDataId undefined | string See ContextRealityModel.realityDataId.  
tilesetUrl string The URL that supplies the 3d tiles for displaying the reality model.  

Defined in

Last Updated: 20 June, 2023