PlanarClipMaskMode Enumeration

The different modes by which a PlanarClipMaskSettings collects the geometry used to mask a model.

extensions

Members

Name Value Description
None 0 No masking.
Priority 1 Mask based on priority. Different types of models have different default priorities as enumerated by PlanarClipMaskPriority.
For example, background maps have the lowest priority, so they are masked by all other types, while design models have the highest priority and are therefore never masked.
The priority of a reality model can be overridden by PlanarClipMaskSettings.priority. This is useful to allow one reality model to mask another overlapping one.
Models 2 Indicates that masks should be produced from the geometry in a set of GeometricModels.
IncludeSubCategories 3 Indicates that masks should be produced from geometry belonging to a set of subcategories.
IncludeElements 4 Indicates that masks should be produced from the geometry of a set of GeometricElements.
ExcludeElements 5 Indicates that masks should be produced from the geometry of all GeometricElements in a view, except for a specified set of excluded elements.

Defined in

Last Updated: 20 June, 2023