clone Method

Create a copy of this PlanProjectionSettings, optionally modifying some of its properties.

clone(changedProps?: PlanProjectionSettingsProps): PlanProjectionSettings

Parameter Type Description
changedProps PlanProjectionSettingsProps JSON representation of the properties to change.

Returns - PlanProjectionSettings

A PlanProjectionSettings with all of its properties set to match those of this, except those explicitly defined in changedProps.

Defined in

Last Updated: 20 June, 2023