TextureTransparency Enumeration

Describes the type of transparency in the pixels of a TextureImage. Each pixel can be classified as either opaque or translucent. The transparency of the image as a whole is based on the combination of pixel transparencies. If this information is known, it should be supplied when creating a texture for more efficient rendering.

see TextureImage.transparency.

Members

Name Value Description
Opaque 0 The image contains only opaque pixels. It should not blend with other objects in the scene.
Translucent 1 The image contains only translucent pixels. It should blend with other objects in the scene.
Mixed 2 The image contains both opaque and translucent pixels. The translucent pixels should blend with other objects in the scene, while
the opaque pixels should not. Rendering this type of transparency is somewhat more expensive.

Defined in

Last Updated: 20 June, 2023