GeometrySummaryVerbosity Enumeration

Describes the level of detail with which to report each geometric primitive in a GeometrySummaryRequestProps.

extensions

Members

Name Value Description
Basic 10 Simply output the type of geometry as a string.
Detailed 20 Output some details of the geometry. e.g., for a sphere, include the center and radius; for a line string, the number of points; etc.
Full 30 Output extremely detailed information. e.g., for a line string, the coordinates of each point. This may produce an enormous amount of data for some primitives.

Defined in

Last Updated: 20 June, 2023