Helmert2DWithZOffset Class
An affine transformation with an additional Z Offset. The equations are: given a = scale * cos(rotation) and b = scale * sin(rotation) X = a * x - b * y + translationX Y = b * x + a * y + translationY Z = z + translationZ
Note that the class only implements the definition and not the operation.
Implements
Methods
Name | Description | |
---|---|---|
constructor(data?: Helmert2DWithZOffsetProps): Helmert2DWithZOffset | ||
equals(other: Helmert2DWithZOffset): boolean | Compares two Helmert2DWithZOffset objects applying a minuscule tolerance. | |
toJSON(): Helmert2DWithZOffsetProps | Creates a JSON from the Helmert Transform definition | |
fromJSON(data: Helmert2DWithZOffsetProps): Helmert2DWithZOffset Static | Creates an Helmert Transform from JSON representation. |
Properties
Name | Type | Description | |
---|---|---|---|
rotDeg | number | The rotation in the trigonometric (CCW) direction in degrees. | |
scale | number | The scale. | |
translationX | number | The X post translation | |
translationY | number | The Y post-translation | |
translationZ | number | The Z post-translation or Z offset |
Defined in
Last Updated: 20 June, 2023