IpcSocket Interface

An inter-process socket connection between a single IModelHost on the backend (the node process), and an IModelApp on the frontend (the browser process.) Each side will implement this interface to form a two way connection. The frontend and backend processes connected through an IpcSocket don't necessarily have to be on the same computer, but often are.

Methods

Name Description
addListener(channel: string, listener: IpcListener): RemoveFunction Establish a handler to receive messages for a channel through a socket.  
removeListener(channel: string, listener: IpcListener): void Remove a previously registered listener  
send(channel: string, ...data: any[]): void Send a message over the socket.  

Defined in

Last Updated: 20 June, 2023