send Method

Send a message over the socket.

send(channel: string, ...data: any[]): void

note data is serialized with the Structured Clone Algorithm, so only primitive types and ArrayBuffers are allowed.

Parameter Type Description
channel string The name of the channel for the message. Must begin with the iTwinChannel prefix.
...data any[] The optional data of the message.

Returns - void

Defined in

Last Updated: 20 June, 2023