lerp MethodStatic

Interpolate between two 0xTTBBGGRR colors using a weighting factor.

lerp(tbgr1: number, tbgr2: number, weight: number): number

Parameter Type Description
tbgr1 number The first color
tbgr2 number The other color
weight number The weighting factor in [0..1]. A value of 0.0 selects tbgr1; 1.0 selects tbgr2; 0.5 mixes them evenly; etc.

Returns - number

The linear interpolation between tbgr1 and tbgr2 using the specified weight.

Defined in

Last Updated: 20 June, 2023