enterEditingScope Method

Begin a new graphical editing scope.

enterEditingScope(): Promise<GraphicalEditingScope>

throws Error if an editing scope already exists or one could not be created.

see GraphicalEditingScope.exit to exit the scope.

see BriefcaseConnection.supportsGraphicalEditing to determine whether this method should be expected to succeed.

see BriefcaseConnection.editingScope to obtain the current editing scope, if one is in progress.

Returns - Promise<GraphicalEditingScope>

Defined in

Last Updated: 20 June, 2023