MapLayerSourceStatus Enumeration

Values for return codes from MapLayerSource.validateSource

Members

Name Value Description
Valid 0 Layer source is valid
InvalidCredentials 1 Authorization has failed when accessing this layer source.
InvalidFormat 2 Provided format id could not be resolved in MapLayerFormatRegistry
InvalidTileTree 3 The tiling schema of the source is not supported
InvalidUrl 4 Could not not connect to remote server using the provided URL.
RequireAuth 5 Authorization is required to access this map layer source.
InvalidCoordinateSystem 6 Map-layer coordinate system is not supported

Defined in

Last Updated: 20 June, 2023