QuantityType Enumeration

Defines standard format types for tools that need to display measurements to user.

Members

Name Value Description
Length 1 Length which is stored in meters. Typically formatted to display in meters or feet-inches based on active unit system.
Angle 2 Angular value which is stored in radians. Typically formatted to display degrees or Degrees-Minute-Seconds based on active unit system.
Area 3 Area value store in meters squared. Typically formatted to display in meters squared or feet squared based on active unit system.
Volume 4 Volume value which is stored in meters cubed. Typically formatted to display in meters cubed or feet cubed based on active unit system.
LatLong 5 LatLong is an angular value which is stored in radians. Typically formatted to display degrees or Degrees-Minute-Seconds based on active unit system.
Coordinate 6 Coordinate/Location value which is stored in meters. Typically formatted to display in meters or feet based on active unit system.
Stationing 7 Stationing is a distance value stored in meters. Typically formatted to display xxx+xx or xx+xxx based on active unit system.
LengthSurvey 8 LengthSurvey is a distance value stored in meters. Typically formatted to display in meters or US Survey Feet based on active unit system..
LengthEngineering 9 LengthEngineering is a distance value stored in meters. Typically formatted to display either meters or feet based on active unit system.

Defined in

Last Updated: 20 June, 2023