GltfMeshPrimitive Interface

A unit of geometry belonging to a GltfMesh. @internal

Extends

-

Properties

Name Type Description
attributes <GltfId> Maps the name of each mesh attribute semantic to the Id of the GltfAccessor providing the attribute's data.  
extensions undefined | & { CESIUM_primitive_outline?: { indices?: GltfId }, EXT_mesh_features?: , KHR_draco_mesh_compression?: }    
indices undefined | GltfId The Id of the GltfAccessor providing the vertex indices.  
material undefined | GltfId The Id of the GltfMaterial to apply to the primitive when rendering.  
mode undefined | The primitive topology type.  
targets undefined | <GltfId> Morph targets - currently unsupported.  

Inherited properties

Name Type Inherited from Description
extras undefined | any  

Defined in

Last Updated: 20 June, 2023