GltfNodeBaseProps Interface

Properties common to Gltf1Node and Gltf2Node. @internal

Properties

Name Type Description
camera undefined | GltfId Currently ignored.  
children undefined | GltfId[] The Ids of the child nodes.  
matrix undefined | number[] A 4x4 column-major transformation matrix.  
rotation undefined | number[] Unit quaternion as [x, y, z, w], where w is the scalar.  
scale undefined | number[] Non-uniform scale as [x, y, z].  
skin undefined | GltfId Currently ignored.  
translation undefined | number[] Translation as [x, y, z].  

Defined in

Last Updated: 20 June, 2023