GraphicBuilderOptions Interface

Options for creating a GraphicBuilder used by functions like DecorateContext.createGraphic and RenderSystem.createGraphic.

see ViewportGraphicBuilderOptions to create a graphic builder for a Viewport.

see CustomGraphicBuilderOptions to create a graphic builder unassociated with any Viewport.

extensions

Properties

Name Type Description
generateEdges undefined | boolean Controls whether edges are generated for surfaces.  
pickable undefined | PickableGraphicOptions If the graphic is to be pickable, specifies the pickable Id and other options.  
placement undefined | Transform The local-to-world transform in which the builder's geometry is to be defined - by default, an identity transform.  
preserveOrder undefined | boolean If true, the order in which geometry is added to the builder is preserved.  
type GraphicType The type of graphic to produce.  
viewIndependentOrigin undefined | Point3d If defined, specifies a point about which the graphic will rotate such that it always faces the viewer.  
wantNormals undefined | boolean Controls whether normals are generated for surfaces.  

Defined in

Last Updated: 20 June, 2023