RenderSystem Namespace

A RenderSystem provides access to resources used by the internal WebGL-based rendering system. An application rarely interacts directly with the RenderSystem; instead it interacts with types like Viewport which coordinate with the RenderSystem on the application's behalf.

Interface

Name Description
RenderSystem.Options Options passed to IModelApp.supplyRenderSystem to configure the RenderSystem on startup.

Defined in

RenderSystem Class

A RenderSystem provides access to resources used by the internal WebGL-based rendering system. An application rarely interacts directly with the RenderSystem; instead it interacts with types like Viewport which coordinate with the RenderSystem on the application's behalf.

see Display system overview

see IModelApp.renderSystem.

extensions

Extended by

  • MockRender.System

Implements

Methods

Name Description
createBranch(branch: GraphicBranch, transform: Transform): RenderGraphic Create a RenderGraphic consisting of a list of Graphics, with optional transform and symbology overrides applied to the list  
createClipVolume(_clipVector: ClipVector): undefined | RenderClipVolume Create a clip volume to clip geometry.  
createGraphic(options: CustomGraphicBuilderOptions | ViewportGraphicBuilderOptions): GraphicBuilder Abstract Obtain a GraphicBuilder from which to produce a RenderGraphic.  
createGraphicBranch(branch: GraphicBranch, transform: Transform, options?: GraphicBranchOptions): RenderGraphic Abstract Create a graphic from a GraphicBranch.  
createGraphicBuilder(placement: Transform, type: GraphicType, viewport: Viewport, pickableId?: string): GraphicBuilder Creates a GraphicBuilder for creating a RenderGraphic.  
createGraphicList(primitives: RenderGraphic[]): RenderGraphic Abstract Create a RenderGraphic consisting of a list of Graphics to be drawn together.  
createGraphicOwner(ownedGraphic: RenderGraphic): RenderGraphicOwner Create a graphic that assumes ownership of another graphic.  
createMaterial(_params: Params, _imodel: IModelConnection): undefined | RenderMaterial Create a RenderMaterial from parameters Deprecated  
createRenderMaterial(_args: CreateRenderMaterialArgs): undefined | RenderMaterial Create a RenderMaterial.  
createScreenSpaceEffectBuilder(_params: ScreenSpaceEffectBuilderParams): undefined | ScreenSpaceEffectBuilder Obtain an object capable of producing a custom screen-space effect to be applied to the image rendered by a Viewport.  
createTexture(_args: CreateTextureArgs): undefined | RenderTexture    
createTextureFromElement(_id: string, _imodel: IModelConnection, _params: Params, _format: ImageSourceFormat): undefined | RenderTexture Create a new texture by its element ID.  
createTextureFromImage(image: HTMLImageElement, hasAlpha: boolean, iModel: undefined | IModelConnection, params: Params): undefined | RenderTexture Create a new texture from an HTML image. Deprecated  
createTextureFromImageBuffer(image: ImageBuffer, iModel: IModelConnection, params: Params): undefined | RenderTexture Create a new texture from an ImageBuffer. Deprecated  
createTextureFromImageSource(source: ImageSource, iModel: undefined | IModelConnection, params: Params): Promise<undefined | RenderTexture> Create a new texture from an ImageSource. Deprecated  
createTextureFromSource(args: CreateTextureFromSourceArgs): Promise<undefined | RenderTexture> Create a texture from an ImageSource.  
findMaterial(_key: string, _imodel: IModelConnection): undefined | RenderMaterial Find a previously-created RenderMaterial by its ID.  
findTexture(_key: TextureCacheKey, _imodel: IModelConnection): undefined | RenderTexture Find a previously-created RenderTexture by its key.  
getGradientTexture(_symb: Symb, _imodel?: IModelConnection): undefined | RenderTexture Obtain a texture created from a gradient.  
waitForAllExternalTextures(): Promise<void> Return a Promise which when resolved indicates that all pending external textures have finished loading from the backend.  
contextLossHandler(): Promise<any> Static A function that is invoked after the WebGL context is lost.  

Properties

Name Type Description
antialiasSamples undefined | number Antialias samples to use on all subsequently created render targets. Beta  
debugControl Accessor ReadOnly undefined | RenderSystemDebugControl Obtain an object that can be used to control various debugging features.  

Defined in

Last Updated: 20 June, 2023