VaryingType Enumeration

The underlying data types that can be used for varying variables in screen-space effect shaders.

see ScreenSpaceEffectBuilder.addVarying to define a varying variable.

extensions

Members

Name Value Description
Float 0 GLSL float.
Vec2 1 GLSL vec2.
Vec3 2 GLSL vec3.
Vec4 3 GLSL vec4.

Defined in

Last Updated: 20 June, 2023