TileUser Namespace

Function

Name Description
TileUser.generateId  
TileUser.viewportsFromUsers Iterate the subset of users that are Viewports.

Defined in

TileUser Interface

Represents some object that makes use of Tiles in some way - e.g., by requesting and/or displaying their contents, querying their geometry, etc. Each Tile keeps track of its users via its TileUsageMarker. A tile with no users is eligible to be discarded view Tile.prune. Every Viewport is a tile user. It is occasionally useful to have a tile user that is not a viewport. Every TileUser is identified by an integer Id that is unique among all extant TileUsers. This Id must be obtained via TileUser.generateId. Every TileUser must be registered with IModelApp.tileAdmin before use via TileAdmin.registerUser and unregistered via TileAdmin.forgetUser after it ceases using tiles.

Implemented by

Methods

Name Description
discloseTileTrees(trees: DisclosedTileTreeSet): void Readonly Disclose all tile trees currently in use by this user.  
onRequestStateChanged(req: TileRequest): void OptionalReadonly An optional function invoked when a TileRequest associated with a Tile in use by this user changes state - e.g., when the request completes, fails, or  

Properties

Name Type Description
iModel Readonly IModelConnection The iModel with which the user is associated.  
tileUserId Readonly number A unique integer identifying this user amongst all extant users.  

Defined in

Last Updated: 20 June, 2023