startDefaultTool Method

Starts the default Tool, if any. Generally invoked automatically when other tools exit, so shouldn't be called directly.

startDefaultTool(): Promise<void>

note The default tool is expected to be a subclass of PrimitiveTool. A call to startDefaultTool is required to terminate an active ViewTool or InputCollector and replace or clear the current PrimitiveTool. The tool's Tool.run method is invoked with arguments specified by ToolAdmin.defaultToolArgs.

see ToolAdmin.defaultToolId to configure the default tool.

Returns - Promise<void>

Defined in

Last Updated: 20 June, 2023