changeBackgroundMapProps Method

Modify a subset of the background map display settings.

changeBackgroundMapProps(props: BackgroundMapProps): void

see backgroundMap for toggling display of the map.

see DisplayStyleState.changeBackgroundMapProvider to change the type of map imagery displayed.

Example that changes only the elevation, leaving the provider and type unchanged:

 style.changeBackgroundMapProps({ groundBias: 16.2 });
Parameter Type Description
props BackgroundMapProps  

Returns - void

Defined in

Last Updated: 20 June, 2023