isLoadingComplete MethodOptional

If defined, returns true if the TileTrees required for displaying this provider's graphics in the specified Viewport are loaded and ready to draw. Otherwise, TileTreeReference.isLoadingComplete is invoked for each reference. A provider might supply this function if it needs to perform some asynchronous work before it can supply its TileTreeReferences and/or after its TileTrees are loaded.

isLoadingComplete(viewport: Viewport): boolean

Parameter Type Description
viewport Viewport  

Returns - boolean

Defined in

Last Updated: 20 June, 2023